Your 1 stop G1 spot.
HomePortalFAQSearchRegisterLog in
Please come rejoin our new and improved forum @! Thanks and sorry for the inconvenience.


 Apps onto SD - problems ive had and things that have helped [for noobs]

Go down 

Posts : 36
Join date : 2009-05-15
Location : cyber space

Character sheet
Which G1 do you have?:
Do you have root?: yes

Apps onto SD - problems ive had and things that have helped [for noobs] Empty
PostSubject: Apps onto SD - problems ive had and things that have helped [for noobs]   Apps onto SD - problems ive had and things that have helped [for noobs] EmptyTue Jun 23, 2009 11:22 am

Originally posted by brandenk

Ok, so since I went from my nice name brand 4GB class4 to a patriot 4GB class6 I have had all kinds of issues trying to get my apps to my SD. When ever I tried to reformat the card through windows vista or win7 it would disconnect, and when trying to launch computer management it would freeze until the phone was disconnected. I would also connect it, right click to format, i would get the popup asking if Im sure I want to format the card, and then when you click format it would fail immediately and the phone would disconnect as external media. So nothing I could do could reformat the card even tho at the time there was a 3.5GB FAT32/.4GB ext2 so I stuck it in Ubuntu. Same weird issues trying to format with GPartition. So I tried Partition manager which would only allow me to delete all the partitions and create ext2 but whenever I would create a FAT32 it would fail at the last 90% of the job and the phone would disconnect form the comptuer, I could then reconnect it and complete the job. I tried this about 20 times after number reboots in Vista and Win7 to no avail. I tried every updated ROM with every type of Apps2sd conversion and nothing is working, everything keeps installing to the phone even after all the commands are successful in the terminal. Finally this morning I got to work and tried with XP and it formatted first try, and now I am midway through resetting everything up. My major issue is that once I install a new build it will work until I setup the apps on the sd card, once I do that I hang on the second slpash screen.

In short I dont know what is going on but I wanted to report my issues incase anyone else was having similar problems. It would seem XP is my savior but that seems really odd.

- SD card not recognized by Windows Vista or Windows 7
- If SD card is detected if you right click > format, that operation will instantly fail and the SD card will become disconnected.
- Opening Admin Tools > Computer Management > Disk Management will hang until you disconnect the SD card
- SD comes up as unallocated and needing a format but any attempt to format it will fail
- After installing Apps2sd it hangs on second splash screen
- After installing Apps2sd it hangs on android logo
- Cyclic Redundancy Check error when copying files to SD
- Phone and computer both not recognizing the SD card

Attempted fixes:
- Installing JFv1.5
- Installing 1.5Hr3Apps2sd
- Installing Dudes Apps2sd
- Installing everything imaginable from radios to RC29 and re-rooting

Chain of events that worked:
- Installed JFv1.5 - get a fresh download, install and wipe. You can do this by using another SD card, putting your SD card in another computer, or using a combo of adb or fastboot. Depending on how I messed up my phone determined which of those ways I could do it.
- Format your whole SD card to FAT32 - Same as above, depending on your situation you may need to use a card reader or a computer with linux or Paragon partition manager. I had more issues in Vista and Win7 than XP just FYI incase thats an option to you.
- Split your partition into FAT32/Ext2 - Take your total card size formatted to FAT32, mine was 3.8GB and I wanted .4GB (400MB) so in the below coding where it says "size" I used 3400M, make sure you use a capital M, for more info on this topic click here. Then, with an internet connection open up your terminal emulator and type each line and then enter:

Quote :
cd /data
chmod 555 sdsplit
/data/sdsplit -fs size -nc

- NOTE - The above 2 steps can be skipped if done in Paragon Partition Manager (which I owe thanks for saving my SD card when the Disk Management in all versions of windows and Gpartition in ubuntu failed to see the card, but not PPM)
- Part 1 of 2 for setting up Apps2sd - First step is to download this file. Extract those 2 files onto the FAT32 (windows visible) partition of your SD card. Then open up your terminal emulator and type out each line and hit enter:

Quote :
mount -o remount,rw /dev/block/mtdblock3 /system
cp /sdcard/init.rc /data/
cp / /data/
cp /sdcard/ /data/

- Part 2 of 2 for setting up Apps2sd - Once fully rebooted download this file and copy the AppstoSD2.apk to your SD card. With a file manager program (ASTRO for me) install AppstoSD2 off of your SD card. When it is done launch the program and select, Copy Apps to SD. Once that is done your phone will reboot. Once its back up and running choose the second option, Copy dalvik-cache to SD. Once that is done you will need to manually reboot.
- DONE!!! - Once I was done rebooting my phone now reports as having ~400MB of internal storage and it feels much snappier. I hope this guide helps someone.

Huge props to Stericson and MarcusMaximus for their help in fixing my phone. I suspect others may run into similar issues not knowing you need to split the sd card, then create those links with init.rc and, and THEN install the appstosd program so maybe this will help someone else.

Update: Phone froze during a call, I pulled the battery, and it hung at the second splash screen, and the JF1.5 file on the SD card could not be found. I went and found my old reliable SanDisk 2GB, put the update on it from my computer, flashed, wiped, and once everything was good to go I tried to put the 4GB class 6 card I have been using but now the phone, linux, xp, vista, win7 all fail to recognize the card at all. I dont know what happened but my issues started when I got that card. I am taking the new Patriot 4GB class 6 card back to fry's and Im running my 4GB class 4 that I had before I upgraded. Everything is setup now and working fine so hopefully I just had a bad SD card.
Back to top Go down

Posts : 5
Join date : 2009-06-26
Age : 45
Location : Chino Hills, CA.

Character sheet
Which G1 do you have?:
Do you have root?: yes

Apps onto SD - problems ive had and things that have helped [for noobs] Empty
PostSubject: Paragon   Apps onto SD - problems ive had and things that have helped [for noobs] EmptyFri Jun 26, 2009 8:59 pm

First off, this is a pretty cool website. i LOVE XDA but dam its so much stuff to work through. Nice to find a place were its categorized how it should be.
Anyway back to topic. I found deleting the partition on my sdcard help a lot. I use Paragon Partition Manager 9 Pro with a card reader and an adapter for my sdcard. Saved me many times. Even now that i understand more I still run into issues connecting and formatting, but with Paragon it has not failed me (knock on wood). Razz

NOTE: DO NOT TRUST FRY'S. I cant stress this enough. All the issues I have had with them on my early years of IT. DAM I HATE THEM! newegg or tigerdirect for me, never failed and returns are quick without any complaints.
Back to top Go down
Apps onto SD - problems ive had and things that have helped [for noobs]
Back to top 
Page 1 of 1
 Similar topics
» Roadmaster climate control/ HVAC problems
» Problems with ST70
» Field Maple problems
» Glossy Accents/Diamond glaze
» KT-120s in a mk3?

Permissions in this forum:You cannot reply to topics in this forum
G1 Addicts :: Modifications :: Root, Hack, & Modify :: Apps2SD-
Jump to: